炒股专用股票监听器可报涨和跌

附件下载

股票监听器.zip

附件大小:9.5 MB

元宝 :100

立即支付

易语言写的股票监听价格变化。
黑白课堂

可自由的切换你想要的股票,例如我现在要切换到君正集团

黑白课堂
黑白课堂
黑白课堂

黑白课堂

那么我们设置好了就好了,可以安心的去工作吧。如果你不想要声音,那么高于和低于价格,就不需要设置了。
只采集 https://www.eastmoney.com/ 这个网站,只用于学习和研究。

易语言代码

.版本 2
.支持库 wke

.程序集 窗口程序集_启动窗口
.程序集变量 倒计时数字, 整数型
.程序集变量 运行目录地址, 文本型

.子程序 _精易Web浏览器1_文档载入完毕
.参数 载入URL, 文本型
.参数 载入状态, 整数型
.参数 失败原因, 文本型
.局部变量 box, WKE_填表

box.文档_置纵向滚动条位置 (精易Web浏览器1.取WebView (), 到整数 (350))
价格.标题 = 到文本 (获取价格 ())

.子程序 _监听开始按钮_被单击

倒计时.时钟周期 = 1000
倒计时数字 = 到整数 (监听时间.内容)

触发时钟.时钟周期 = 到整数 (监听时间.内容) × 1000

倒计时文字.标题 = 到文本 (倒计时数字)

.子程序 _按钮2_被单击

精易Web浏览器1.URL = 编辑框1.内容

.子程序 获取价格, 小数型
.局部变量 tbx, WKE_填表
.局部变量 价格数字获取值, 小数型
.局部变量 价格高, 小数型
.局部变量 价格低, 小数型
.局部变量 价格上升基数, 小数型

价格上升基数 = 到小数 (tbx.文档_取元素内容 (精易Web浏览器1.取WebView (), #填表模式_JS表达式, “#km1”, 1))

价格数字获取值 = 到小数 (tbx.文档_取元素内容 (精易Web浏览器1.取WebView (), #填表模式_JS表达式, “#price9”, 1))
.如果 (价格上升基数 < 0)
    价格.文本颜色 = #绿色
.否则
    价格.文本颜色 = #红色
.如果结束

价格高 = 到小数 (价格高于框.内容)
价格低 = 到小数 (价格低于框.内容)

.如果 (价格高 ≠ 0 且 价格数字获取值 ≥ 价格高)
    涨声音 ()

.否则

.如果结束

.如果 (价格低 ≠ 0 且 价格数字获取值 ≤ 价格低)
    跌声音 ()
.否则

.如果结束

返回 (价格数字获取值)

.子程序 _设置时间按钮_被单击

倒计时数字 = 到整数 (监听时间.内容)
触发时钟.时钟周期 = 到整数 (监听时间.内容) × 1000
倒计时文字.标题 = 到文本 (倒计时数字)

.子程序 _监听结束按钮_被单击

触发时钟.时钟周期 = 0
倒计时.时钟周期 = 0

.子程序 _触发时钟_周期事件

价格.标题 = 到文本 (获取价格 ())
标题 = 到文本 (获取价格 ())

.子程序 _倒计时_周期事件

倒计时数字 = 倒计时数字 - 1
倒计时文字.标题 = 到文本 (倒计时数字)
.如果 (倒计时数字 ≤ 0)
    倒计时数字 = 到整数 (监听时间.内容)
.否则

.如果结束

.子程序 __启动窗口_创建完毕

运行目录地址 = 取运行目录 ()
涨价声音地址.内容 = 运行目录地址 + “\gupiaoUp.mp3”
跌价声音地址.内容 = 运行目录地址 + “\gupiaoDown.mp3”

.子程序 _按钮1_被单击

.子程序 涨声音

停止播放 ()
播放MP3 (2, 涨价声音地址.内容)

.子程序 跌声音

停止播放 ()

播放MP3 (2, 跌价声音地址.内容)

.子程序 _价格_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型

提示

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
黑白课堂

黑白课堂

混元大罗金仙 站长创业者玉树凌风每天醒来0收入

查看更多

最新视频课程

Laravel 的 PhpSpreadsheet 包入门

wap2App 入门讲解,100%速成,全面为你讲解。

ace.js 打造一款属于你的 Web 编辑器,入门文档。

Laravel Permission 中文文档

解释 OAuth 2.0 认证 和使用场景说明

Laravel 实现 RBAC 权限管理功能 Permission 包操作

钻级赞助商