Windows 下执行 cmd 定时任务易语言软件,方便执行 Laravel 的控制台命令

附件下载

cmd定时器.zip

附件大小:340 KB

元宝 :0

立即下载

定时任务

黑白课堂

前面"/c"表示执行完毕之后关闭 ,如果你想要保持的话,则输入 "/k",后面空格,接着就要执行的命令,比如我想要执行 laravel 的 artisan 命令。
可写

/c php d:/www/wwwroot/demo/artisan list

命令语法

/c或/c 空格 命令指令

易语言源码

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 时间倒计时, 整数型

.子程序 _时钟1_周期事件
.局部变量 i, 整数型
.局部变量 命令, 文本型

.计次循环首 (超级列表框1.取表项数 (), i)
    命令 = 超级列表框1.取标题 (i - 1, 1)
    执行命令 (命令)
.计次循环尾 ()

.子程序 执行命令
.参数 命令, 文本型

运行 (“cmd.exe ” + 命令, 假, 2)

.子程序 __启动窗口_创建完毕

.子程序 _添加_被单击
.局部变量 索引, 整数型

.如果 (命令框.内容 = “”)
    信息框 (“命令不能为空”, 0, , )
    返回 ()
.否则

.如果结束
索引 = 超级列表框1.插入表项 (, , , , , )
超级列表框1.置标题 (索引, 0, 到文本 (索引 + 1))
超级列表框1.置标题 (索引, 1, 命令框.内容)

.子程序 _按钮3_被单击

.如果 (周期框.内容 = “”)
    信息框 (“周期时间不能为空”, 0, , )
    返回 ()

.否则

.如果结束
时钟1.时钟周期 = 到整数 (周期框.内容) × 1000
时间倒计时 = 到整数 (周期框.内容)
标签1.标题 = 到文本 (时间倒计时)

.子程序 _执行按钮_被单击

.如果 (超级列表框1.取表项数 () ≤ 0)
    信息框 (“没有要执行的任务”, 0, , )
    返回 ()

.否则

.如果结束

时钟2.时钟周期 = 1000
.如果 (时钟1.时钟周期 ≤ 0)
    信息框 (“请设置周期”, 0, , )
    返回 ()

.否则

.如果结束
时钟1.时钟周期 = 到整数 (周期框.内容) × 1000
时间倒计时 = 到整数 (周期框.内容)
标签1.标题 = 到文本 (时间倒计时)

.子程序 _时钟2_周期事件

时间倒计时 = 时间倒计时 - 1
.如果 (时间倒计时 ≤ 0)
    时间倒计时 = 到整数 (周期框.内容)
.否则

.如果结束
标签1.标题 = 到文本 (时间倒计时)

.子程序 _停止按钮_被单击

时钟2.时钟周期 = 0
时钟1.时钟周期 = 0

.子程序 _按钮1_被单击

超级列表框1.全部删除 ()

.子程序 _按钮2_被单击

.判断循环首 (超级列表框1.现行选中项 ≠ -1)
    超级列表框1.删除表项 (超级列表框1.现行选中项)

.判断循环尾 ()

提示

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
黑白课堂

黑白课堂

混元大罗金仙 站长创业者玉树凌风每天醒来0收入

查看更多

最新视频课程

Laravel 的 PhpSpreadsheet 包入门

wap2App 入门讲解,100%速成,全面为你讲解。

ace.js 打造一款属于你的 Web 编辑器,入门文档。

Laravel Permission 中文文档

解释 OAuth 2.0 认证 和使用场景说明

Laravel 之 horizon 队列管理界面系统

钻级赞助商