易语言入门之拖入文件导入到超级列表框表格内

介绍

导入文本到列表框里面,拖入到这个区域即可
描述

制作流程

  • 超级列表框
    • 显示表格线:真
    • 类型:报表列表框
  • 拖放对象
    • 接受文件:真

描述
描述
描述

知识点

  • 超级列表框
  • 拖放对象
  • 分割文本
  • 转换编码

流程

  • 注册拖放控件
  • 文件处理拖入事件

代码

描述
描述

.版本 2
.支持库 edroptarget
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (超级列表框1.取窗口句柄 ())

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

导入数据 (接收到的文件路径)

.子程序 导入数据
.参数 接收到的文件路径, 文本型
.局部变量 文件号, 整数型
.局部变量 文件类型, 文本型
.局部变量 文件内容, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 n, 整数型
.局部变量 插入索引, 整数型
.局部变量 文本内容数组, 文本型, , "0"

超级列表框1.全部删除 ()

文件类型 = 文件_取类型 (接收到的文件路径)
.如果真 (文件类型 ≠ “文本文档”)
    信息框 (“请选择txt文件”, 0, , )
    返回 ()
.如果真结束

文件内容 = 到文本 (读入文件 (接收到的文件路径))
文件内容 = 编码_utf8到gb2312 (文件内容)
文本数组 = 分割文本 (文件内容, #换行符, )

.如果真 (取数组成员数 (文本数组) = 0)
    信息框 (“文本内容为空”, 0, , )
    返回 ()
.如果真结束
.计次循环首 (取数组成员数 (文本数组), n)
    文本内容数组 = 分割文本 (文本数组 [n], “----”, )
    插入索引 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (插入索引, 0, 到文本 (插入索引 + 1))
    超级列表框1.置标题 (插入索引, 1, 文本内容数组 [1])
    超级列表框1.置标题 (插入索引, 2, 文本内容数组 [2])
    超级列表框1.置状态图片 (插入索引, 1)
.计次循环尾 ()

文件格式

你好----黑白课堂的易语言教程
黑白课堂----推出易语言入门教程
小白----学习易语言

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。